obey-robots.txt
03 December 2016, 14:35
Navigatie
Ledenenquête
Heb je de oplossing voor je probleem op dit forum gevonden/gekregen?

Ja
Ledenenquête: Heb je de oplossing voor je probleem op dit forum gevonden/gekregen? Ja 39% [88 stemmen]
39% [88 stemmen]

Nee
Ledenenquête: Heb je de oplossing voor je probleem op dit forum gevonden/gekregen? Nee 61% [136 stemmen]
61% [136 stemmen]

Stemmen: 224
U dient in te loggen om te stemmen.
Gestart: 25 jun 2009

Enquête-archief
Steun ons
Inloggen / Registreren
Gebruikersnaam

Wachtwoord


Nog geen lid?
Als geregistreerd lid kunt u reageren en alle extra functies gebruiken.
Online Gebruikers Groep
Wachtwoord vergeten?
Verzoek nieuw wachtwoord.
Onderwerp bekijken
Waarvoor en hoe gebruik je een switch, router of een access point achter dit modem? Hoe krijg ik mijn NAS, netwerkprinter, enz. in mijn netwerk? Hoe deel ik mijn web-, smtp-, ftp-, enz. server met anderen op het internet? Hoe kan ik online spellen spelen op mijn xbox, ps3, wii, psp, enz.? Hoe sluit ik mijn iphone, ip-tv, ip-telefoon, ata, enz. aan op deze router en moet ik dan nog speciale dingen instellen?
 Nieuw onderwerp  Beantwoorden
 Onderwerp afdrukken

Mailserver OSX Leopard

Martyin
Beste lezers..
Zijn er mensen hier die ervaring hebben met OSX Server?

Ik probeer een mailserver in de lucht te krijgen.. loop echter tegen wat probleempjes aan.. Ik ben het fff kwijt.
probleem is dat mail bestemt voor mijn server niet binnen komt.
Lijkt op firewall probleem maar die staat uit. Ik heb even gezocht op het net.... naar mogelijke filtering van online, maar die zijn onduidelijk. De HD zegt inderdaad dat alles dicht zit. Maaar dat geloof ik niet. En een techneut krijg je niet aan de lijn.
Wat ik gedaan heb:
Bij andere provider : domein naam geregistreerd, dns record toegevoegd. alle verkeer komt op het vaste ip uit van mijn "online" account. Ik heb de poorten open gezet in de live box.
poort 80 is werkend. Als ik dus van "buiten" naar de server hier ga kan ik browsen.
Daarna op de zelfde manier poort 25 open gezet.

Mail server configuratie is vrij complex. Is een OSX server laatste versie.
Via server Admin alles in gesteld.
Echter :
Uitgaand verkeer is ok.
Inkomend: niets.
Het rare is dat wanneer ik een telnet ter controle doe naar het vaste ip op poort 25 komt er ook niets.
Het "lijkt" dus alsof de boel geblokt wordt. (of de firewall niet goed staat , of de instelling van de mailserver geen connecties van "buiten acepteert) Maar gezien de verhalen van hierboven en de werkende situ in het verleden moet het gewoon werken.
Is er iemand die me fff op weg kan helpen?
Ik weet bv. niet meer of ik wel of niet in de serveradmin een relay adres van het vaste IP moet opgeven.

Graag jullie hulp

Martin


PS

De helpdesk is nog steeds echt kloten.
Die begrijpen niets van wat je vraagt.

" in mijn scherm staat dat inkomend en uitgaand mail verkeer via poort 25 geblokt wordt."
aldus de helpdesker.
 
TCP_IP
Sorry geen ervaring met OSX server.

Maar misschien dat ik er een licht op kan werpen.

Even met putty getelnet:

telnet 213.x.x.x 25

220 e-sys.nl ESMTP Postfix

telnet 213.x.x.x 110

Niet bereikbaar

(heb meteen je site vast gezien Pfft, ziet er goed uit )

Je pop-server is dus te vinden.
Maar in je omschrijving noem je niks over poort 110.
Moet even terugdenken maar ik dacht dat voor mailserver zo zat:

pop 25 = mail verzenden vanaf mailserver

smtp 110 = mail ontvangen op mailserver

en voor clients dan andersom.

Dus probeer eens om poort 110 te forwarden naar je mailserver.

Livebox heeft een bug, ondersteund geen NATloopback. Daarom kon je het met telnet niet controleren, dat in ieder geval verklaard.

Maar alsnog geen ervaring met OSX en minimale ervaring met mailservers (nog).
Transmission Control Protocol over Internet Protocol

Voor al je Windows en PC problemen kun je terecht op www.xpvista.nl !
 
Martyin
ok, dankje tot dusver...
ik heb de poort 110 ook geforward maar nog geen result

De telnet heb ik ok gedaan van buiten.
Ik heb nog een xs4all account die ik gebruik om eerst een ssh telnet naar xs4all te doen en dan weer terug naar de livebox.
dus zou er bij moeten kunnen.
Maar het vreemde is dat de lokale telnet naar de server wel goed gaat.

telnet 192.168..x.x 25
HELO mail
e-sys

maar telnet 213.x.x.x 25
niet mogelijk

daarom ga je denken dat het toch een NAT issue is
Ik kreeg hierom de indruk dat de inkomende mail toch geblokt wordt door online.
Die mensen weten echter niet hoe het zit.

als je nog meer ideeen hebt.... graag
 
TCP_IP
Wat ik nog weet is dat er wel iets geblokkeerd word op poort 25, maar meerdere mensen hebben het al werkend.

Ik weet wel wie je eigenlijk echt moet hebben hiervoor, dat is Rrozema of Richard. 2 andere beheerders van dit forum, alleen Richard is op dit forum niet zo actief meer. Maar je zou ze beide eens een PM kunnen sturen of afwachten tot Rrozema dit topic leest.

Rrozema
Richard

Het is idd een NAT issue (of livebox issue Pfft).

Heb nog even portping laten lopen, results:


----- STARTUP -----
WSAStartup() succeeded

User supplied IP Address. No name resolution required...
Success! Pinged port 110 in 109 milliseconds
Port 110 still going...

User supplied IP Address. No name resolution required...
Success! Pinged port 25 in 94 milliseconds
Port 25 still going...




Dit zegt mij dat poorten geen probleem zijn, die zijn beide bereikbaar en er draait een service achter.

Ik denk nog even verder voor je ...
Transmission Control Protocol over Internet Protocol

Voor al je Windows en PC problemen kun je terecht op www.xpvista.nl !
 
rrozema
pop3: toegang tot je mail box (ophalen van mail):
Je kunt je eigen pop3 server draaien op je online aansluiting. Als je clients enkel vanaf je eigen netwerk verbinding maken met je pop3 server, hoef je voor de pop3 server geen port forwards aan te maken. Als je echter ook clients hebt die vanaf een andere internet aansluiting bij jouw server hun mail ophalen dan moet 1 port forward aanmaken: TCP poort 110 naar het interne ip adres van je pop3 server.

smtp: inkomende mail ontvangen en mail versturen:
Je kunt je eigen smtp server draaien op je online aansluiting. Om mail te kunnen ontvangen moet je altijd een port forward aanmaken: TCP poort 25 naar het interne ip adres van je smtp server. In een naïeve poging de verspreiding van spam tegen te gaan blokkeert Online alle netwerkverkeer uitgaand van je online aansluiting gericht aan poort 25 van elk ip adres anders dan dat van een van de Online smtp servers. In de praktijk betekent dit dat jouw smtp server niet zelf mail kan afleveren bij de server van de bestemming van je emails. Gelukkig kan je de meeste smtp programma's dusdanig instellen dat ze een relay server gebruiken om hun uitgaande mail af te leveren. Stel je smtp programma in zodat hij smtp.online.nl als relay host gebruikt. Voor deze verbinding hoef je geen user naam en/of wachtwoord op te geven. Helaas ondersteunen de smtp servers van Online geen beveiligde verbindingen (ssl), dus al je mail zal wel onbeveiligd over het internet gaan. Bovendien bewaart Online net als alle providers, in opdracht van de Nederlandse overheid -naïeve beslissingnemers heb je tenslotte op alle niveaus- een kopie van alle via haar servers verstuurde email.
 
rrozema
Martyin schreef:
Het rare is dat wanneer ik een telnet ter controle doe naar het vaste ip op poort 25 komt er ook niets.
Het "lijkt" dus alsof de boel geblokt wordt. (of de firewall niet goed staat , of de instelling van de mailserver geen connecties van "buiten acepteert) Maar gezien de verhalen van hierboven en de werkende situ in het verleden moet het gewoon werken.


Als je test vanaf een andere Online aansluiting (en hetzelfde geldt voor een flink aantal andere providers) dan wordt de verbinding naar poort 25 van jouw ip adres geblokkeerd door de eerder genoemde blokkering van poort 25. Ook als je telnet naar die poort, jouw ip adres is immers niet een van de smtp servers van Online. Dat is de enige verklaring die ik nu even kan bedenken, anders dan de normale redenen:
  • de forward staat niet goed/niet aan in je router,

  • de firewall op je computer laat poort 25 niet door,

  • het smtp programma niet draait op je pc of

  • je pc heeft een ander intern ip adres gekregen.


edit:typootje weggehaald
 
Martyin
Hoi,
Als eerste bedankt voor het meedenken...
Ik zal proberen de stappen te beschrijven...

* de forward staat niet goed/niet aan in je router,
zie bijlage (schrmafdruk firewall)

* de firewall op je computer laat poort 25 niet door,
Dit is dus een Live box. Vertel maar wat ik verder kan instellen dan de poort "open te zetten"
Zie verder geen extra instellingen. Ik heb gewoon het externe vaste ip gekoppeld aan het interne server adres. (OSX Leopard Server 10,5,x officieel met gekochte licentie)

* het smtp programma niet draait op je pc of
Die draait wel. Er is vermoedelijk iets anders

* je pc heeft een ander intern ip adres gekregen.
Het is een Mac Pro. Het OS is Darwin (Unix Like) versie 10.5.x
Ik maak gebruik van de Server Admin Tool
Het lijkt wel of je een helpdesk vragenlijstje afwerkt. Grin


Uitgaande mail werkt wel. Op de client is ingesteld dat de relay via de smtp van orange moet lopen. Dat gaat gewoon goed.
Inkomende niet. Angry
Mar 18 08:51:44 zwoov pop3s[98011]: AOD: mbr_check_service_membership with access_all_services
Mar 18 08:51:44 zwoov pop3s[98013]: AOD: mbr_check_service_membership with access_all_services
Mar 18 08:51:44 zwoov pop3s[98013]: AOD: mail service ACL NOT enabled
Mar 18 08:51:44 zwoov pop3s[98011]: AOD: mail service ACL NOT enabled
Mar 18 08:51:44 zwoov pop3s[98011]: login: [192.168.1.10] peter APOP+TLS User logged in
Mar 18 08:51:44 zwoov pop3s[98013]: login: [192.168.1.10] jan APOP+TLS User logged in
Mar 18 08:51:45 zwoov imap[98054]: login: [192.168.1.10] kees CRAM-MD5+TLS User logged in
Mar 18 08:51:45 zwoov imap[98054]: quota set to "unlimited" for mailbox user.peter
Mar 18 08:51:45 zwoov imap[98054]: seen_db: user peter opened /var/imap/user/x/xantine.seen
Mar 18 08:51:45 zwoov imap[98054]: open: user peter opened Apple Mail To Do
Mar 18 08:51:45 zwoov imap[98050]: seen_db: user peter opened /var/imap/user/x/xantine.seen
Mar 18 08:52:17 zwoov master[99920]: about to exec /usr/bin/cyrus/bin/imapd
Mar 18 08:52:17 zwoov imap[99920]: executed
Mar 18 08:52:17 zwoov imap[99920]: accepted connection\
Mar 18 08:52:17 zwoov imap[99934]: login: [192.168.1.10] martin CRAM-MD5 User logged in
Mar 18 08:52:17 zwoov imap[99934]: quota set to "unlimited" for mailbox user.martin
Mar 18 08:52:17 zwoov imap[99934]: seen_db: user martyin opened /var/imap/user/m/martin.seen
Mar 18 08:52:17 zwoov imap[99934]: open: user martin opened Apple Mail To Do

De telnet sessie:
zwoov:~ root# telnet 192.168.1.10 25
Trying 192.168.1.10...
Connected to 192.168.1.10.
Escape character is '^]'.
220 bla.nl ESMTP Postfix
HELO MAIL
250 bla.nl

Vanuit extern, meerdere account aanwezig, werkt het niet. (We hebben meerdere mogelijkheden om een externe connectie open te zetten vanuit volledig andere netwerken dan online. vanuit de zelfde locatie.Cool

Wat moet ik als relay opgeven bij de " accept smtp relay from the following hosts"
ik had er al staan het eigen netwerk...
192.168.1.0/24 (Voor de minder ervaren lezers: de /24 betekend x.x.x.0 tot x.x.x.255
binnen het netwerk.

Niet mogelijk om buitenkant te zien, we zitten met een NAT. die van de live box...
dus volgens mij niet noodzakelijk om de IP van de hete kant te noemen.


Iemand?


Thanx
Gewijzigd door Martyin op 18 maart 2009, 09:12
 
Martyin
Ik vond net dit in de logfiles van de mailserver .
"delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]: Connection refused"

Iemand en idee hoe dat kan?
Ik dacht aan DNS, maar werkt goed, kan alles doen....
vreemd...
Als iemand weet hoe dit opgelost kan worden hoor ik het graaag....


MAIL komt WEL binnen.
Echter.....
Dit is een leuke ..
connection refused verhaal van hierboven is er dus de reden van dat mail niet binnenkomt,...
connect to 127.0.0.1[127.0.0.1]: Connection refused staat in de mail loggings
Weet iemand oplossing?
Gewijzigd door Martyin op 18 maart 2009, 10:09
 
Martyin
Ok, het lijkt te werken.
Ik heb het volgende gevonden..

-Tell Postfix not to use the content-filter
Edit /etc/postfix/main.cf and comment out #content_filter = smtp-amavis:http://127.0.0.1:10024
Issue:
sudo postfix reload
sudo postsuper -r ALL

Did the trick...

pfff.

Voor de goede orde:
Een eigen malserver draaien bij "online" kan gewoon.
Alleen het uitgaande verkeer wordt gefilterd, je moet dus bij "outgoing mailserver " een ander adres invullen dan je "eigen smtp" server adres, namelijk dat van online.

Hopende dat het een bruikbare bijdrage levert aan iedereen.



Iedereen bedankt voor het meedenken.

Wink
Gewijzigd door Martyin op 18 maart 2009, 10:41
 
rrozema
Mooi zo. Ik werkte ook net zo'n lijstje af als de helpdesk dat doet. Wink Dit lijstje zat weliswaar in mijn hoofd; het waren alle mogelijke redenen die ik kon verzinnen waarom dit niet goed ging. Uiteindelijk zijn de lijstjes die een helpdesk afwerkt op precies dezelfde manier ontstaan; door alle mogelijke oorzaken onder elkaar te zetten en die stuk voor stuk uit te sluiten. In jouw geval was het dus
* de firewall op je computer laat poort 25 niet door,
die jij foutief beantwoordde met
Dit is dus een Live box. Vertel maar wat ik verder kan instellen dan de poort "open te zetten"
Zie verder geen extra instellingen. Ik heb gewoon het externe vaste ip gekoppeld aan het interne server adres. (OSX Leopard Server 10,5,x officieel met gekochte licentie)
Er staat namelijk niet dat de firewall in de livebox je verkeer tegehoudt, maar die van je computer. Toegegeven, het is in jouw geval niet een specifiek firewall product op je computer maar het is wel exact dezelfde functionaliteit; op basis van herkomst en bestemming voor een netwerk pakket beslissen of het wel of niet doorgelaten mag worden.

Ik ben blij dat je de oplossing zelf gevonden hebt, want het is voor ons, niet mac gebruikers, erg lastig om dit op te lossen omdat we jouw software niet kennen en ook niet op onze pc's voor je kunnen uitproberen. Ik vind trouwens de mac nog steeds een geweldig apparaat (heb vroeger nog gewerkt op een power Mac), ik ben alleen gezwicht voor de massa; ik heb een pc omdat iedereen er mee werkt, da's gewoon wel zo gemakkelijk.

Trouwens, je hebt nu het filter helemaal uitgeschakeld, waarschijnlijk kun je ook het 127.0.0.1 adres wel toevoegen in het zelfde filter als waar je je 192.168.1.0/24 reeks hebt toegevoegd. Controleer voor de zekerheid nog even of je nu geen open relay bent. (waardoor bijvoorbeeld spammers jouw mail server zouden kunnen gebruiken om hun spam te versturen.) Dat kun je bijvoorbeeld doen op spamhelp.org. Vink niet het checkboxje aan want als je dan toch een relay blijkt te zijn, sta je gelijk op de block list en heb je er een probleem bij Wink
Gewijzigd door rrozema op 19 maart 2009, 06:19
 
Spring naar forum:
 Nieuw onderwerp  Beantwoorden
Gebruik BBcode of HTML om naar; 'Mailserver OSX Leopard', te verwijzen!
BBcode:
HTML:
Vergelijkbare onderwerpen
Onderwerpen Forum antwoorden Laatste bericht
Mailserver geeft aan dat mijn account niet klopt. Storing 2 16 oktober 2014, 18:53
Problemen met mailserver!!! Storing 6 31 juli 2011, 00:36
2011-06-08 07:26:53 > Problemen met de mailserver - Update 15:00 Storing 7 29 juli 2011, 16:52
Hoi (mailserver zwolle) Algemeen 6 14 oktober 2009, 21:01
Eigen mailserver werkt niet meer na livebox update Algemeen 9 31 juli 2009, 21:41
Goedemiddag bezoeker
Inloggen / Registreren
Gebruikersnaam

Wachtwoord



Nog geen lid?
Als geregistreerd lid kunt u reageren en alle extra functies gebruiken.

Wachtwoord vergeten?
Verzoek nieuw wachtwoord.
Laatst geziene leden
| Johan401:40:05
| Tiger03:01:26
| dutch flash04:05:14
| Roroko04:15:44
| Wanabo04:24:36
| Lutz08:12:00
| Ronsworld15:08:49
| ronald schuit15:14:50
| okkie_199417:10:43
| trebor60 1 dag
Shoutbox
U moet ingelogd zijn om een bericht te plaatsen.

15 november 2016, 21:47
Online.nl=amateurs

05 november 2016, 16:44
Hallo allemaal, Vanaf 18 oktober heb ik geen verbinding meer. Bijna elke dag bellen met klantendienst, 5 a 6 keer emailen naar de klantenservice niets opgelost. Nog steeds geen verbinding dus geen

01 november 2016, 19:42
in helmond dezelfde storing

27 oktober 2016, 23:15
@ MGuitink Om weer in het modem te komen, eerst restten via het verzonken knopje aan de zijkant van het modem.

27 oktober 2016, 13:39
Hoe kan ik het wachtwoord voor mijn huawei hg655d opnieuw instellen?