obey-robots.txt
08 December 2016, 16:57
Navigatie
Ledenenquête
Heb je de oplossing voor je probleem op dit forum gevonden/gekregen?

Ja
Ledenenquête: Heb je de oplossing voor je probleem op dit forum gevonden/gekregen? Ja 39% [89 stemmen]
39% [89 stemmen]

Nee
Ledenenquête: Heb je de oplossing voor je probleem op dit forum gevonden/gekregen? Nee 61% [137 stemmen]
61% [137 stemmen]

Stemmen: 226
U dient in te loggen om te stemmen.
Gestart: 25 jun 2009

Enquête-archief
Steun ons
Inloggen / Registreren
Gebruikersnaam

Wachtwoord


Nog geen lid?
Als geregistreerd lid kunt u reageren en alle extra functies gebruiken.
Online Gebruikers Groep
Wachtwoord vergeten?
Verzoek nieuw wachtwoord.
Onderwerp bekijken
Wat is er mogelijk met het modem en hoe doe je het? Hoe kom je in het configuratiescherm? Heeft deze router wireless? Waar vind je wat in de schermen? Kun je nog extra dingen instellen, bijv. via telnet? Zijn er problemen bekend met dit modem? en hoe los je ze op?
 Nieuw onderwerp  Beantwoorden
 Onderwerp afdrukken

Uitschakelen van "ADI Convergence Galaxy update FTP server"

Nox
Hoi allemaal,

Wie zou mij kunnen vertellen hoe ik die vreselijke "ADI Convergence Galaxy update FTP server" kan uitschakelen?

Of iig een manier weten hoe ik die livebox zo gek kan krijgen dat hij ftp-requests op de mer0 interface van binnenuit niet zelf probeert af te handelen, maar netjes terugstuurd naar binnen (dus eigenlijk ook port-forwarding, maar dan aan de binnenkant).

De reden voor dit vreemde verzoek is passive-ftp. ftp-servers achter een firewall moeten altijd het externe IP terugsturen naar de clients die verbinden via het internet. Als je dat niet insteld stuurt de server het IP trug van de interface waar hij het request op binnen krijgt. Dat werkt prima voor lokale clients, maar niet voor clients op het internet. ANdersom werkt weer prima voor clients op het internet, maar niet voor lokale clients, omdat ze van de server het externe IP teruggestuurd krijgen en, jewel, daar draait de "ADI Convergence Galaxy update FTP server"!........

PS. Nog even een ander probleem. ZIjn er meer mensen waarbij de Livebox na ongeveer een week/anderhalve week helemaal vastloopt en pas weer werkt nadat je de stekker eruit hebt getrokken en er weer in hebt gedaan?

Please help.... ik word knettergek van dat ding. (active ftp is GEEN optie)
 
Richard
Euh... ik maak vaker gebruik van passive ftp, heb er hier ook eentje draaien en clients krijgen dan het interne ip adres te zien met nog wat nummertjes er achter, dat werkt verder prima.
Dus ik weet niet wat jij bedoeld met dat je altijd het externe ip zou moeten terugsturen. Da's helemaal niet nodig.

Heb je wel genoeg poorten open voor passive ftp?

Greetings, Richard.
 
Nox
Ja dat klopt. Maar dat gedeelte werkt ook naar behoren omdat de livebox daar niet tussen zit. De meeste ftp-servers die in passive-mode zijn geconfigureerd sturen default het interne ip-adres naar de client terug, nadat de client het PASV-command naar de server heeft gestuurd (dit is in de praktijk het ip-adres waar de ftp-server de aanvraag op binnenkrijgt).

Dit werkt echter niet voor clients die via het internet verbinden. Die krijgen namelijk OOK dat IP toegestuurd en de kans is groot dat, mocht te client toevallig ook in een LAN zitten, die dan toevallig ook nog dezelfde range gebruikt, waar toevallig ook nog een PC is met dat IP, dan nog is de kans erg klein dat dat een ftp-server is.

Nu kun je dit wel omzeilen. Sommige ftp-servers hebben een optie waarin je expliciet het IP-adres kunt opgeven die naar de client wordt gestuurd. meestal heet die optie 'pasv_address' in de meeste unix ftp-servers. Ook dat werkt prima, maar alleen voor de internet clients en NIET voor de LAN-clients, want die krijgen nu ook dat IP adres teruggestuurd en willen dus met de publieke (internet kant) van de livbox verbinden van binnenuit, en daar gaat het mis. De livebox vertaald dit niet goed terug (dat proces heet local loopback) en probeert dit zelf af te handelen (de ADi Galaxy ftp update service) ipv dat hij het netjes doorstuurd naar binnen (de eigenlijke ftp-server).

Ik hoop niet dat dit een te ingewikkeld verhaal is. Mochten er nog dingen onduidelijk zijn, vraag ze gewoon.

Met vriendelijke groet,

Frans
 
Beest
pfff na dit verhaal kom ik er niet als noobie

heb sinds vanmorgen LB aanstaan en draaien
heb al verschillende dingen met succes weten te forwarden
behalve ftp
is er ook iets met poort 21 toevallig? dat LB die blokt ofzo
zelfs al zet ik er die bij in de lijst van lb firewall
en verander ik de poort naar bv 32 van het ftp prog....
nog kan er niet geconnect worden.

nu staan er in de LB heel wat meer router opties dan in mijn vorige modem
en daar was het port forwarding ook automatisch NAT ingesteld .
nu heb ik daar nix staan in lb
ook zie ik inderdaad bij policies
gebaseerde NAT , dat hij Redir Port 192.168.1.10 van / naar 192.168.1.10 poort 119 119
klopt toch ook niet helemaal
want daar zou dan toch mijn ext ip moeten staan?


tips of suggesties??

want routering is niet mijn specialty
 
Richard
Sorry maar ik snap dat probleem echt niet hoor.
Ik kan zelfs externe -en- interne clients laten verbinden met een eenvoudige ftp server als Bulletproof FTP server.

Maar je kunt toch gewoon ftp en pasv naast elkaar gebruiken? De locale clients loggen dan op het interne ip adres in op de ftp, niets aan de hand, de externe clients via internet loggen middels pasv op het externe ip adres in.

Het zou aan de firewall kunnen liggen van de Livebox, ik las ook wat van die ADI op franse forums, maar ik kan niet meer goed frans lezen dus dan houdt het al snel op.

Bij mij staat de firewall uit en heb ik gewoon alle poorten geroute naar mijn Linuxmachine die verder de routing en firewalling vor zijn rekening neemt.
Misschien kun je hier wat mee? Staan ook nog wat tips in:
http://www.adslforum.nl/topic.asp?TOPIC_ID=14593&whichpage=2

Greetings, Richard.
 
Beest
aaarg dit gaat lastig worden

ik ben niet zo op de hoogte met al die instellingen

ik heb al vanalles geprobeerd, maar via die test site net2ftp.com
kan ik ook totaal niet connecten
helaas heb ik geen 2e comp om zelf te testen
maar naar mijn weten is toch alles geforwarded
om te beginnen heb ik dus ook de poort maar naar 44499 gezet
maar op die link van je staat het ook weer een beetje verkeerd omschr
nl :
4. Configureer de livebox als volgt:
menu-standaard>LAN server>toevoegen en vul nu in:
Naam server: FTP server
Toegang geactiveerd: ja
Protocol: TCP
van poort: 44499 naar poort: 44499
Lokal IP-adres : IP Adres van je PC waarop de server draait, dus 192.168.x.x

als ik lanserver druk , kan ik niets toevoegen
dus er zal wel bedoeld worden"firewall"
{of op oudere LB moet dan anders zijn }
maar goe dan kan ik dus idd de poort open zetten.... dun
in sp2 is overal het zelfde gedaan dan
maar dah was gister dus ook al met de andere poorten 21 , 32
zelfs bPftp op passive gezet
nog niets...... geen movement.

als mijn maatje op t ext ip probeerd in te loggen dan komt ie niet ver..
waarschijnlijk blokt de router gewoon alles..
de shields up test op http://www.grc.com
geeft ook aan dat alles stealth loopt


in de documentatie of op de site vind ik ook niet direct een beschijving van de modem!!
en het enige wat ik nog kan bedenken is om de firewall te deactiveren in LB..
maar das natuurlijk ook niet ideaal

in theorie zou het dan wel moeten werken ,, maar ik zou het toch normaal ook werkend moeten krijgen
het liefst sta ik niet passive ingesteld
de LB is toch statisch of ??
ik weet ook niet wat mer0 is zogezegt , want ik gebruik toch echt de ethernet kabel..
en daarom komt mijn kennis ook niet verder dan poortjes invoeren..
sorry.
ik ken wel iemand die goed frans kent, dus vertaling is mogenlijk.
 
Beest
idd nu gaat het wel

als ik de firewall uitzet van LB.. ist opgelost

maar wel raar dat ik torrent en newsleecher wel geconfigureerd krijg met firewall aan..... poorten geforward.... sp2 ingesteld en t loopt prima.

maar met ftp dus niet...

wel logisch natuurlijk
dat als ik ftp niet passive wil, dat ik dan de router ook zo moet aanpassen
maar ookal staat de firewall van LB aan, dan nog is mijn extern ip toch statisch ????
dacht ik .. dan zou ik het toch ook vloeiend moeten kunnen forwarden of ?
niet....

iedergeval wij zijn weer blij...
voor het eerst dat het metertje naar mb's schiet :-)
 
Richard
Kijk dat scheelt. Wat betreft het extern ip adres en het statisch zijn. Het lijkt statisch maar daadwerkelijk is het een dynamisch ip adres, hang er maar eens een ander modem aan of modem/router, dan heb je een ander mac-adres en hups ook een ander ip adres.

Feitelijk ligt je ip adres min of meer vastgelegd in de dhcp database, dus als je opnieuw inlogt krijg je je eigen ip weer terug.
Maar het werkt nog altijd via DHCP en kan altijd nog wijzigen dus daadwerkelijk is het een dynamisch ip.
Doch dat maakt verder niet zoveel uit wat de forwarding betreft in dit geval.

Ik heb het vermoeden dat als de firewall van de Livebox aan staat, de ftp poort gereserveerd is op een of andere manier, net als poort 80 die dan gereserveerd is voor de configuratie van de Livebox.
Als namelijk poort 80 niet naar een intern ip geforward is, kunnen in de meeste gevallen mensen die ook op Orange zitten en je ip weten, gewoon de configuratie van je Livebox benaderen.

Met een forward van poort 80 is dat grapje afgelopen, volgens mij ook als je de firewall uit zet.

Ik vermoed dus dat iets soortgelijks ook voor de FTP poort geldt.

Maar in elk geval fijn te horen dat je het weer werkend gekregen hebt!Smile
Greetings, Richard.
 
Nox
Hoi allemaal, sorry voor mijn trage reactie. Ik heb dit weekend weining tijd gehad om me met internet bezig te houden.

Richard,

Voor internet het een passive en voor de locale clients iets anders zou idd een oplossing zijn, zij het niet dat er een aantal clients zijn die PER SE passive willen gebruiken, wat ik me ook wel een beetje kan voorstellen, omdat active ftp eigenlijk toch niet echt meer van deze tijd is en je dat ook eigenlijk helemaal niet meer wil. Ik denk dat ondersteuning voor active-ftp in de nabijetoekomst dan ook helemaal zal verdwijnen.

Omdat het probleem idd nogal exotisch is zal ik aan de hand van wat scherm-output laten zien wat er gebeurd met verschillende instellingen.

Ik zal als ftp-programma alleen gebruik maken van 'ftp' wat standaard in zowel windows, als de meeste UNICES aanwezig is. Verder zal ik 2 host gebruiken. 'taniquetil', een lokale host in Leiden met IP: 192.168.2.11'. Dit is tevens de FTP-server (vsftpd), en 's30' met een publiek IP-adres. Dit een host in Redbus Amsterdam. De hostname 'taniquetil.homeunix.net' is een DynDNS hostname die naar het publieke IP-adres van mijn Livebox verwijst. Niet te verwarren met 'taniquetil.hethuis.nl' wat een interne host is met een lokaal gehoste domeinnaam.

Configuratie 1)
Download broncode  Code
# Setup Passive Mode
pasv_min_port=60000
pasv_max_port=60010
#pasv_address=85.146.141.249



Merk op dat er nu niet expliciet een ip-adres naar de client wordt gezonden. Volgens de manual van Vsftpd: "pasv_address: Use this option to override the IP address that vsftpd will advertise in response to the PASV command. Provide a numeric IP address.
Default: (none - the address is taken from the incoming connected socket)". '192.168.2.11' dus.

Middels passive-ftp inloggen vanuit 'taniquetil':
Download broncode  Code
[fcoppens@taniquetil.hethuis.nl 18:14 ~] > ftp -pdv taniquetil
Connected to taniquetil.hethuis.nl.
220 (vsFTPd 2.0.5)
ftp: setsockopt: Bad file descriptor
Name (taniquetil:fcoppens):
---> USER fcoppens
331 Please specify the password.
Password:
---> PASS XXXX
230 Login successful.
---> SYST
215 UNIX Type: L8
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
ftp: setsockopt (ignored): Permission denied
---> PASV
227 Entering Passive Mode (192,168,2,11,234,103)
---> LIST
150 Here comes the directory listing.
drwxr-x---    2 ftp      ftp           360 Oct 27 10:27 Desktop
lrwxrwxrwx    1 ftp      ftp             5 Sep 15 15:31 data -> /data
drwxr-x---    4 ftp      ftp            96 Oct 19 18:20 smb4k
-rw-r-----    1 ftp      ftp             0 Oct 23 20:28 trackers
226 Directory send OK.
ftp>


Dit werkt dus kennelijk best aardig.

Nu vanuit 's30' in Redbus:
Download broncode  Code
[fcoppens@taniquetil.hethuis.nl 18:19 ~] > ssh root@83.98.x.x
Password:
Last login: Mon Oct 30 18:09:35 2006 from s55928df9.adsl.wanadoo.nl
s030:~# hostname -f
s030.networking4all.com
s030:~# ftp -pdv taniquetil.homeunix.net
Connected to taniquetil.homeunix.net.
220 (vsFTPd 2.0.5)
ftp: setsockopt: Bad file descriptor
Name (taniquetil.homeunix.net:root): fcoppens
---> USER fcoppens
331 Please specify the password.
Password:
---> PASS XXXX
230 Login successful.
---> SYST
215 UNIX Type: L8
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
---> PASV
227 Entering Passive Mode (192,168,2,11,234,101)
ftp: connect: Connection timed out
ftp>


Dit gaat dus niet zo goed. Viel natuurlijk te verwachten, gezien het IP adres wat 's30' terug krijgt van de FTP-server.

Config 2)
Download broncode  Code
# Setup Passive Mode
pasv_min_port=60000
pasv_max_port=60010
pasv_address=85.146.141.249




Van binnenuit 'taniquetil':
Download broncode  Code
[fcoppens@taniquetil.hethuis.nl 19:03 ~] > ftp -pdv taniquetil
Connected to taniquetil.hethuis.nl.
220 (vsFTPd 2.0.5)
ftp: setsockopt: Bad file descriptor
Name (taniquetil:fcoppens):
---> USER fcoppens
331 Please specify the password.
Password:
---> PASS XXXX
230 Login successful.
---> SYST
215 UNIX Type: L8
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
ftp: setsockopt (ignored): Permission denied
---> PASV
227 Entering Passive Mode (85,146,141,249,234,100)
ftp: connect: Connection refused
ftp>


Dit gaat kennelijk fout en dat is niet logisch*.

Vanuit 's30':
Download broncode  Code
s030:~# ftp -pdv taniquetil.homeunix.net
Connected to taniquetil.homeunix.net.
220 (vsFTPd 2.0.5)
ftp: setsockopt: Bad file descriptor
Name (taniquetil.homeunix.net:root): fcoppens
---> USER fcoppens
331 Please specify the password.
Password:
---> PASS XXXX
230 Login successful.
---> SYST
215 UNIX Type: L8
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
---> PASV
227 Entering Passive Mode (85,146,141,249,234,101)
---> LIST
150 Here comes the directory listing.
drwxr-x---    2 ftp      ftp           360 Oct 27 10:27 Desktop
lrwxrwxrwx    1 ftp      ftp             5 Sep 15 15:31 data -> /data
drwxr-x---    4 ftp      ftp            96 Oct 19 18:20 smb4k
-rw-r-----    1 ftp      ftp             0 Oct 23 20:28 trackers
226 Directory send OK.
ftp>


Dit werkt dan verder weer wel goed.

* De reden waarom de tweede configuratie niet werkt is niet logisch. DIt zou namelijk wel moeten werken. Ik VERMOED dat het probleem in de NAT implementatie van de Livebox zit. Normaal gesproken (bij Linksys routers iig) worden 'interne' verzoeken op de publieke kant op port 21 ook netjes teruggekoppeld naar binnen. De Livebox doet dit echter niet en probeert het zelf af te handelen en sluist het verzoiek door naar de ADI Convergense FTP server. En dat is zeker NIET de bedoeling.

Nog even om te laten zien dat het echt de LIvebox is die zich ermee bemoeid. FTP login van buiten en vervolgens vanuit binnen naar hetzelfde IP-adres.
Download broncode  Code
s030:~# ftp -pdv taniquetil.homeunix.net
Connected to taniquetil.homeunix.net.
220 (vsFTPd 2.0.5)
ftp: setsockopt: Bad file descriptor
Name (taniquetil.homeunix.net:root):

[fcoppens@taniquetil.hethuis.nl 19:25 ~] > ftp -pdv taniquetil.homeunix.net
Connected to taniquetil.homeunix.net.
220 Welcome to the ADI Convergence Galaxy update FTP server v1.0.
ftp: setsockopt: Bad file descriptor
Name (taniquetil.homeunix.net:fcoppens):




Ik kan verder maar een 'oplossing' bedenken maar die vind ik persoonlijk nogal absurd en dat is mijn Linksys router die nu tussen de Livebox en het interne netwerk zit van als NAT gateway te configuren ipv als router en de desbetreffende poorten 2x te forwarden. De firewall in de Livebox uitschakelen werkt niet.

Sorry voor het lange verhaal, maar ik hoop dat nu duidelijk is wat wat het probleem is en waar het mis gaat.
Gewijzigd door Nox op 30 oktober 2006, 19:16
 
Lizard
Het is een bekend iets dat de Livebox niet aan NAT loopback doet.

De oplossing is om in je interne netwerk je host file aan te passen of het interne ip adres te gebruiken, vanaf de buitenkant kan je je publieke ip gebruiken. Ik heb zelf soms ook een ftp openstaan op een linux machine, dit werkt zonder problemen.
 
Spring naar forum:
 Nieuw onderwerp  Beantwoorden
Gebruik BBcode of HTML om naar; 'Uitschakelen van "ADI Convergence Galaxy update FTP server"', te verwijzen!
BBcode:
HTML:
Vergelijkbare onderwerpen
Onderwerpen Forum antwoorden Laatste bericht
Waarschuwing firmware update ZyXEL VMG8324-B10A! Zyxel configuratie en problemen 49 06 november 2016, 18:12
Firmware update tool Online.nl Zyxel configuratie en problemen 1 14 oktober 2016, 12:53
ftp server Huawei configuratie en problemen 4 14 februari 2016, 23:46
HG655d update Huawei configuratie en problemen 5 06 januari 2016, 17:20
Teamspeak 3 server poortforwarden mislukt steeds? Algemeen 4 29 december 2015, 12:09
Goedemiddag bezoeker
Inloggen / Registreren
Gebruikersnaam

Wachtwoord



Nog geen lid?
Als geregistreerd lid kunt u reageren en alle extra functies gebruiken.

Wachtwoord vergeten?
Verzoek nieuw wachtwoord.
Laatst geziene leden
| Tiger< 5 mins
| Wanabo02:11:48
| Huubke6804:18:02
| dutch flash05:16:19
| peukevreugd06:12:57
| Ronsworld17:51:48
| earlgrey7219:15:15
| Hans20:00:40
| Ano20:30:47
| dutch123:13:07
Shoutbox
U moet ingelogd zijn om een bericht te plaatsen.

07 december 2016, 12:08
iemand weet welke firmware huawei hg665d op dit moment zit?

15 november 2016, 21:47
Online.nl=amateurs

05 november 2016, 16:44
Hallo allemaal, Vanaf 18 oktober heb ik geen verbinding meer. Bijna elke dag bellen met klantendienst, 5 a 6 keer emailen naar de klantenservice niets opgelost. Nog steeds geen verbinding dus geen

01 november 2016, 19:42
in helmond dezelfde storing

27 oktober 2016, 23:15
@ MGuitink Om weer in het modem te komen, eerst restten via het verzonken knopje aan de zijkant van het modem.